At time of writing, Microsoft has not yet released a full protection upgrade for the latest IE vulnerability, thus leaving any IE user of the above-mentioned versions at potential risk of being hacked and having their data stolen.

The IE vulnerability could allow remote malicious code execution. It would therefore allow a hacker to gain full system control with the same privileges as you.

According to Microsoft, the vulnerability is being actively exploited for zero-day exploits.

 StormShield truly unique HIPS is able to proactively block even the most sophisticated targeted attacks on the IE latest vulnerability.

StormShield users are automatically protected and do not require to update StormShield in this case for the solution will proactively block the attack before it’s materialized.

More information here :
http://technet.microsoft.com/en-us/security/advisory/2794220